This site uses cookies. By continuing to browse the site, you are agreeing to our use of cookies. Find out more

Web browser and add-ons for on-line services

Information about browser and add-on requirements for using our website and on-line services.

As of February 2020, you need to use a modern browser such as Chrome, FireFox, Edge to use our site. An updated device running Android or iOS will also work well.

If you use an older browser, version of Andriod (4.4 KitKat or older) or an older Apple / Safari browser, you will need to upgrade your device. You can check if your browser supports TLS 1.2 at:

If you are using any of our on-line services and use Citrix Receiver we recommend that you update the Workspace app to version 1911 or later to be safe. It is available for download at https://www.citrix.com/downloads/